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MagIC Net 4.2

Installation instructions

1 Minimum system requirements

Operating system 64-bit version of:

￭ Windows 11 Pro / Enterprise
￭ Windows 10 Pro / Enterprise
￭ Windows Server 2022
￭ Windows Server 2019
￭ Windows Server 2016

RAM 8 GB

Hard disk space Program: 1 GB

Data:

￭ Minimum: 10 GB
￭ Recommended: 50 GB

Serial ports for devices with RS-232 interface

USB ports for devices with USB interface

Screen Minimum resolution: 1024 x 768

Network 10 Mbit/s, stable and permanent

Communication via TCP/IP

Safety systems, e.g. firewalls, have an impact on
performance.

PDF reader A PDF reader must be installed on the computer.

Optimized
performance

Performance improvements are available from
MagIC Net 4.2. Existing databases and methods must
be migrated into another data format on a one-time
basis to improve performance after a MagIC Net
update (see chapter 6.2, page 15).

The Windows user must have administrator rights in order to be able to install
the MagIC Net software.
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2 Customizing energy options

During the determination, data loss may occur or there may be communication
problems with certain energy options of the operating system. Proceed as fol-
lows to customize the energy-saving plan settings:

1 Under Control Panel ▶ System and Security ▶ Energy Options,
open the system settings that specify the behavior when the power
switch is pressed or the computer is folded shut.

 

2 Change the following settings:

￭ When pressing the power switch: Do nothing
￭ When pressing the energy saving button: Do nothing
￭ When closing the lid: Do nothing
￭ Enable fast start-up: Deactivated

NOTE

To change the Turn on fast start-up option, you may need to enable
it first as an administrator. To do this, click on Some settings are cur-
rently unavailable in the window.

 

3 Open the energy-saving plan settings under Control Panel ▶ System
and Security ▶ Energy Options. Now click on Change advanced
energy settings.

 

4 Change the following settings:

￭ Under Saving energy:
– Deactivation after: Never
– Allow hybrid standby mode: Off
– Hibernate after: Never

￭ Under USB settings:
– Selective USB energy-saving settings: Disabled

 

5 If communication problems occur, proceed as follows:

Open the Device manager via the Windows start menu.

Maximize the USB controller entry.

Open the context menu of the USB controller used with the right mouse
button. Disable the Computer can switch off the device to save
energy option under Properties ▶ Energy management.

If it is not known which USB controller is used, then adjust the properties
of all USB controllers.
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3 Single workplace installation

With the single workplace version MagIC Net Basic, MagIC Net Compact
or MagIC Net Professional, you can install both the MagIC Net client and
the server on the computer.

1 Prior to the installation, disconnect all the USB devices from the computer
on which MagIC Net is to be installed.

If the OMNIS Software is already installed on the computer, exit the
Metrohm OMNIS DeviceServer service via the Windows Task Manager.

 

2 Connect the USB flash drive with the MagIC Net installation file to the
computer and start the setup.exe file.

If the minimum system requirements are not met (see above), a corre-
sponding message appears. Click on [Yes] if you would like to install the
program nonetheless.

Afterwards, click on [Next >].

 

3 During the installation process, the Welcome screen appears first. Click on
[Next >] to install the software.

 

4 Read the license agreement for MagIC Net and accept it with [Yes].

 

5 After having accepted the license agreement, a window will appear
where you can enter the license code.
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Enter the license code for MagIC Net Basic, MagIC Net Compact or
MagIC Net Professional and then click on [Next >].

NOTE

If you have entered the license code of an update license, then the
license code of the previous full version will additionally be requested.

 

6 Confirm the target folder for the MagIC Net installation with [Next >] or
select a different target folder with [Browse…].
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7 You can define the paths for the database files and default backup files in
the Additional installation information window:

NOTE

The default paths are different for the various operating systems.

The database path must not be on a network drive.

The default backup path may also be on a network drive.

You can change the ports MagIC Net uses to communicate with the
database server and the administration server with the [Advanced…]
button. If the ports are already used, an appropriate error message will
appear. Ask your system administrator for more information about this.
Continue with [Next >].
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8 If you would like to create a shortcut on your desktop to start the
MagIC Net software, activate [Yes] and then click on [Next >].

 

9 Confirm the program folder with [Next >] or select a different program
folder.

 

10 The installation settings can now be checked. Start the copy process with
[Next >].
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11 The following message appears during the installation of MagIC Net:

This message points out again which ports MagIC Net uses. Write down
these ports and inform your system administrator in case MagIC Net is
not able to connect to the database. Confirm the message with [OK].

MagIC Net will now be installed.

NOTE

During the installation, all device drivers that are required for control-
ling the supported USB devices are installed or updated.

Anti-virus programs can prevent the unpacking of the device drivers. If
an error occurs, exclude the installation pathway for MagIC Net from
the virus scan.

If the driver software needs to be updated, a message appears. Con-
firm the installation by clicking on the [Install] button.

 

12 Once the copying procedure has been completed, you can make further
workplace settings:
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The option This client ID must exist in the current MagIC Net sys-
tem. can only be activated if a database from a previous installation
already exists or if you want to connect to a database server on another
computer.

If you enable this option, then MagIC Net checks whether the identifier
you have entered exists in the database. If this is the case, the identifier
and all associated settings will be adopted. With this option, reinstalling a
client is much easier.

Click on [Next >]. If the database ports are not available, an appropriate
error message will appear and the installation will be canceled. In this
case, check your server and firewall settings before installing the program
again.

 

13 At the end of the installation, the file info.txt will be created. This file
contains all relevant information concerning your current MagIC Net
installation. Save this file on your hard drive for future reference and print
it (add to installation qualification).

NOTE

An InstallLog file can be found in the installation directory of
MagIC Net under …bin\InstallLog. It contains a listing of all files
copied to your computer during the installation and a confirmation that
the installation has been successfully completed.

 

14 Complete the installation with [Finish].

If the OMNIS Software is already installed on the computer, restart the
Metrohm OMNIS DeviceServer service via the Windows Task Manager.
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Fonts

For the correct display of East Asian fonts (e.g. in reports), it may be necessary
to add the corresponding fonts. There are two options to do this. Carry out
only one of the two described options.

￭ Install the missing language: Windows Settings ▶ Time & Lan-
guage ▶ Language ▶ Add a language

￭ Download the fonts for all languages: Windows Settings ▶ Personaliza-
tion ▶ Fonts ▶ Download fonts for all languages

The procedure may differ from the described procedure, depending on the
Windows version and operating system build used. Additional information on
how to proceed can be found under Language packs for Windows.

4 Client/server installation

With the MagIC Net multi version (multi-client version with 3 licenses) you
can select during the installation whether you want to install only a Client or a
client and a server (database server) on your computer.

If you want to install only a client on your computer, a server to which the cli-
ent will be connected must have been previously installed on another com-
puter.

1 Follow steps 1 to 6 of the single workplace installation (see chapter 3,
page 3).

 

2 The Additional installation information dialog appears. Here you can
select whether you want to install only a client or a client and a server
(database server) on your computer.

The option Client/Server installs the client and the database server on
your computer. Select this option if your computer will be used as server.

https://support.microsoft.com/windows/language-packs-for-windows-a5094319-a92d-18de-5b53-1cfc697cfca8#WindowsVersion=Windows_11
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NOTE

The default paths are different for the various operating systems.

The database path must not be on a network drive.

The default backup path may also be on a network drive.

With Client, only the client will be installed and you have to select the

database server you would like to use with the  button. The database
server must already be installed. The network server name or the IP
address is accepted as the name.

You can change the ports MagIC Net uses to communicate with the
database and administration server with the [Advanced…] button. If the
ports are already used, an appropriate error message will appear. Ask your
system administrator for more information about this. Continue with
[Next >].

 

3 All further installation steps correspond to those of the single workplace
installation from point 8 onwards (see chapter 3, page 3).

Fonts

For the correct display of East Asian fonts (e.g. in reports), it may be necessary
to add the corresponding fonts. There are two options to do this. Carry out
only one of the two described options.

￭ Install the missing language: Windows Settings ▶ Time & Lan-
guage ▶ Language ▶ Add a language

￭ Download the fonts for all languages: Windows Settings ▶ Personaliza-
tion ▶ Fonts ▶ Download fonts for all languages

The procedure may differ from the described procedure, depending on the
Windows version and operating system build used. Additional information on
how to proceed can be found under Language packs for Windows.

5 Modifying/repairing/removing the installation
and upgrading the license

In order to carry out modifications on the current MagIC Net installation, start
the setup.exe file from the USB flash drive or click under:

Control panel ▶ Programs ▶ Programs and Features on Metrohm
MagIC Net. Then select Uninstall/Change:

https://support.microsoft.com/windows/language-packs-for-windows-a5094319-a92d-18de-5b53-1cfc697cfca8#WindowsVersion=Windows_11
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Modify

With this option you can adjust the paths to the database and backup files and
change the ports which MagIC Net uses for communication.

With the MagIC Net Multi version you can additionally change the path to
the database server.

If the database path is changed, the existing databases are automatically
copied to the new location.

Repair/Update

With this option you can repair an existing defective installation or update an
older installation.

￭ Repairing the installation
In case of a defective MagIC Net installation because, for instance, a DLL
file is missing or a program file has been deleted by mistake, MagIC Net
can be repaired with this option.

￭ Updating the installation
In case an older version of MagIC Net is installed, it will be updated to the
new version of MagIC Net. For MagIC Net Compact / Professional, see
Chapter 6, page 12. For MagIC Net Multi, see Chapter 7, page 20.

CAUTION

During the updating of older MagIC Net versions to MagIC Net 4.2, the
databases will be converted to the new version. Depending on the database
size, this may take some time. A progress bar showing the status of the con-
version is displayed for each database.

The computer must not be restarted or Windows shut down as long as the
conversion is running!

Database migration for performance optimizations must be started manually
after the update of MagIC Net regardless of the conversion to the latest
database version (see chapter 6.2, page 15).
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License upgrade

A direct upgrade of your current installation to a MagIC Net version with
additional features is possible with this option:

￭ MagIC Net Compact to MagIC Net Professional or MagIC Net Multi
￭ MagIC Net Professional to MagIC Net Multi

In order to do this, enter your new license code in the next dialog window.

Remove

This option removes your MagIC Net installation. Data which has been gener-
ated after the installation (e.g. database entries, log files, exported data, etc.)
will not be deleted.

6 Program update with MagIC Net Compact/
Professional

During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically
updated for further use with the new version of MagIC Net Compact/
Professional.

NOTE

The files in the database and backup directory will be retained when the
program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

6.1 Program update

Program update

 

1 Save the configuration database to an external directory using the backup
function of MagIC Net. In the Configuration program part, select the
File ▶ Save ▶ Manually menu item. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is car-
ried out. Then copy the backup file to an external storage medium.

 

2 If desired, export the methods to an external directory in addition to the
backup with the configuration database (see above). To accomplish this,
select the File ▶ Method manager… menu item in the Method pro-
gram part. Select the desired Method group, mark all of the methods to
be exported and click on [Edit] ▶ Export…. Select the desired export



8.0102.8016EN / v1 / 2023-06-30 13

directory and click on [OK]. The methods are exported to the desired
directory. Then copy the method files to an external storage medium.

 

3 Save all determination databases created by you to an external directory
using the backup function of MagIC Net. In the Database program
part, select the File ▶ Database manager… menu item. Select the
desired database and click on [Backup]. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is car-
ried out. Then copy the backup file to an external storage medium.

 

4 Also save further files created by you in the installation directory (e.g.,
export files) to an external directory or to an external storage medium.

 

5 Close MagIC Net. Connect the USB flash drive with the installation file to
the computer and start the setup.exe file. Then select Repair/Update
program and click on [Next >].

 

6 Enter the update license code for MagIC Net Compact or MagIC Net
Professional and click on [Next >].
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7 CAUTION

During the updating of older MagIC Net versions to MagIC Net 4.2, the
databases will be converted to the new version. Depending on the
database size, this may take some time. A progress bar showing the
status of the conversion is displayed for each database.

The computer must not be restarted or Windows shut down as long as
the conversion is running!

Database migration for performance optimizations must be started
manually after the update of MagIC Net regardless of the conversion to
the latest database version (see chapter 6.2, page 15).

Complete the installation with [Finish].

NOTE

An UpdateLog file with a list of all files that have been copied to your
computer during the program update and with a confirmation of a suc-
cessful installation is saved in the MagIC Net installation folder
(default: C:\Program Files(x86)\Metrohm\MagIC Net) under bin\Install-
Log.
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6.2 Migrating databases and methods

Performance improvements are available from MagIC Net 4.2. Existing data-
bases and methods must be migrated into another data format on a one-time
basis to improve performance.

NOTE

Perform the migration of databases and methods only when updating to
MagIC Net 4.2.

Metrohm recommends migrating all databases and methods after updating
to MagIC Net 4.2.

NOTE

Depending on the database size, migration may take some time. A progress
bar shows the status of the migration.

During migration, MagIC Net cannot be used elsewhere.

Prerequisite:

￭ To migrate databases and methods, they must not be open. Check to
ensure that no databases or methods are open on any client.

 

1 Open database management with Database ▶ File ▶ Database man-
agement….

In the database table, the line headers are highlighted in yellow. The
entries in the Name field are highlighted in blue. This means that the
database migration is still pending. Once migration has been performed,
the marking disappears.

 

2 NOTE

Each database must be migrated individually. Multiple databases can-
not be migrated at the same time. Do not start the migration of a data-
base until after any previous migrations have been completed.

Select a database. Perform migration with [Process] ▶ Migrat-
ing... ▶ Migrating.

Perform this step for all databases.

 

3 Open the method manager with Method ▶ File ▶ Manage
methods… ▶ Manage methods.
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In the method table, the line headers are highlighted in yellow. The
entries in the Name field are highlighted in blue. This means that the
method migration is still pending. Once migration has been performed,
the marking disappears.

 

4 Select all methods. Perform migration with [Process] ▶ Migrat-
ing... ▶ Migrating.

All databases and methods were migrated. MagIC Net runs with
improved performance.

6.3 Checking access rights

If MagIC Net 3x is upgraded to a version with new access rights or security set-
tings, then following behavior may occur:

The access rights are structured hierarchically (tree structure). If new child
nodes are added to an existing node in the new program version, then the
child nodes are enabled by default. The child nodes are enabled even if the
user did not have permission for the parent node in the previous program ver-
sion. The parent node settings may also change as a result of the update.

NOTE

After updating from MagIC Net 3.x to a higher version, check the access
rights and adjust them if necessary.

If MagIC Net is upgraded to a version other than the next higher version, check
the access rights added in the intervening versions as well.

Example: If an update from MagIC Net 3.0 to MagIC Net 4.2 is performed,
check the access permissions that were added in MagIC Net 3.1, MagIC Net
3.2, MagIC Net 3.3 and MagIC Net 4.0.

New access rights in MagIC Net 3.1

￭ Database ▶ View ▶ Previous determination
￭ Database ▶ View ▶ Next determination
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New access rights in MagIC Net 3.2

￭ Method ▶ Functions ▶ Time program ▶ Edit ▶ New
￭ Method ▶ Functions ▶ Time program ▶ Edit ▶ Edit
￭ Method ▶ Functions ▶ Time program ▶ Edit ▶ Copy
￭ Method ▶ Functions ▶ Time program ▶ Edit ▶ Insert
￭ Method ▶ Functions ▶ Time program ▶ Edit ▶ Cut
￭ Method ▶ Functions ▶ Time program ▶ Edit ▶ Delete
￭ Method ▶ Functions ▶ Time program ▶ Edit ▶ Change time
￭ Method ▶ Functions ▶ Time program ▶ Edit ▶ Insert subprogram
￭ Method ▶ Functions ▶ Time program ▶ Edit ▶ Rename subpro-

gram
￭ Method ▶ Functions ▶ Time program ▶ Edit ▶ Delete subprogram
￭ Method ▶ Functions ▶ Time program ▶ Edit ▶ Go to...
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New access rights in MagIC Net 3.3

￭ Database ▶ Functions ▶ Reprocess ▶ Method... ▶ Save as...
￭ Database ▶ Functions ▶ Reprocess ▶ Method... ▶ Change column
￭ Database ▶ Functions ▶ Reprocess ▶ Method... ▶ Change eluent
￭ Database ▶ Functions ▶ Reprocess ▶ Method... ▶ Import calibra-

tion points
￭ Database ▶ Functions ▶ Reprocess ▶ Method... ▶ Export calibra-

tion points



8.0102.8016EN / v1 / 2023-06-30 19

New access rights in MagIC Net 4.0

￭ Method ▶ Functions ▶ Devices ▶ Edit
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6.4 Importing configuration data

If a configuration database with security settings or user administration is
imported, the settings of the imported configuration database are not applied
immediately.

Do not print the configuration report directly after importing a configuration
database. The printed settings do not correspond to the actual settings.

Check the security settings and user administration after importing a configura-
tion database. Otherwise there is a risk of being excluded from the application.
After the settings have been checked, restart the computer.

Print the configuration report only after restarting the clients, if desired.

7 Program update with MagIC Net Multi

During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the server are automatically updated for further use with the new
version of MagIC Net Multi.

NOTE

The files in the database and backup directory will be retained when the
program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

7.1 Program update

1 Make sure MagIC Net Multi is closed on all clients.

NOTE

In the bin subdirectory of the MagIC Net installation, you can find the
Clients.exe application, with which all clients and their status can be
displayed.

 

2 Open MagIC Net Multi on the server and save the configuration data-
base into an external directory using the backup function of MagIC Net.
In the Configuration program part, select the File ▶ Save ▶ Manually
menu item. Select the Backup directory, enter a name for the backup
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file and click on [Start]. The backup is carried out automatically. Then
copy the backup file to an external storage medium.

 

3 If desired, export the methods in addition to the automatic backup with
the configuration database (see above) into an external directory. To
accomplish this, select the File ▶ Method manager… menu item in the
Method program part. Select the desired Method group, mark all of
the methods to be exported and click on [Edit] ▶ Export…. Select the
desired export directory and click on [OK]. The methods are exported to
the desired directory. Then copy the method files to an external storage
medium.

 

4 Save all of the determination databases on the server to an external direc-
tory using the backup function of MagIC Net. In the Database program
part, select the File ▶ Database manager… menu item. Select the
desired database and click on [Backup]. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is car-
ried out automatically. Then copy the backup file to an external storage
medium.

 

5 Also save further files created in the installation directory (e.g. export files)
to an external directory or to an external storage medium.

 

6 Updating the server

Close MagIC Net Multi on the server and on all clients. Connect the USB
flash drive with the installation file to the computer and start the
setup.exe file. Then select Repair/Update program and click on [Next
>].

 

7 Enter the update license code for MagIC Net Multi and click on [Next
>].
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8 NOTE

The update of MagIC Net Multi consists of the server license and
three client licenses. If an existing installation contains additional client
licenses, these will be deleted.

Click on [OK] in the corresponding message in order to continue the
installation.

 

9 CAUTION

During the updating of older MagIC Net versions to MagIC Net 4.2, the
databases will be converted to the new version. Depending on the size
of the database, this may take some time. A progress bar showing the
status of the conversion is displayed for each database.

The computer must not be restarted or Windows shut down as long as
the conversion is running!

Database migration for performance optimizations must be started
manually after the update of MagIC Net regardless of the conversion to
the latest database version (see chapter 6.2, page 15).

Complete the installation with [Finish].
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NOTE

An UpdateLog file with a list of all files that have been copied to the
server during the program update and with a confirmation of a suc-
cessful installation is saved in the MagIC Net installation folder
(default: C:\Program Files(x86)\Metrohm\MagIC Net) under the server's
bin\InstallLog.

 

10 In case additional licenses have been removed during the server update,
or if further additional licenses are to be added, the Administrator can
enter them in MagIC Net (dialog: Configuration ▶ Tools ▶ Program
administration ▶ Licenses ▶ Add licenses) (see chapter 7.2, page
24).

 

11 Updating clients

Connect the USB flash drive with the installation file to each client in turn
and start the setup.exe file. Then select Repair/Update program and
click on [Next >]. Complete the installation with [Finish].

NOTE

To facilitate the updating of many clients at once, the installation can
be copied from the USB flash drive to a writable medium and the file
magic_init.ini can be modified. There, user-defined parameters for
the installation (license code, installation path, server name, etc.) can
be set in advance, so that one needs only click through the installation.

An UpdateLog file with a list of all files that were copied to the client
computer at the time of a program update and with a confirmation of the
success of the installation can be found in the MagIC Net client's instal-
lation folder (standard: C:\Program Files(x86)\Metrohm\MagIC Net) under
bin\InstallLog.
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7.2 Adding additional licenses

If additional licenses were removed at the time of the server update or if fur-
ther additional licenses are to be added, proceed as follows:

1 Open the directory C:\Users\'Username\AppData\Local\VirtualStore
\Program Files (x86)\Metrohm\MagIC Net\bin. If there is a file there
named license.mlic, delete it. Repeat this for each user.

 

2 Right-click on the file setup.exe and select Run as administrator.

 

3 Add the desired licenses in the Configuration program part under
Extras ▶ Program administration ▶ Licenses ▶ Add licenses.

The file license.mlic, which contains the standard license code and the
additional license codes, is stored in the bin directory of the program
installation (e.g., C:\Program Files(x86)\Metrohm\MagIC Net\bin).

NOTE

For additional information on adding additional licenses, please refer to
Chapter 8, page 25.

7.3 Migrating databases and methods

Performance improvements are available from MagIC Net 4.2. Existing data-
bases and methods must be migrated into another data format on a one-time
basis to improve performance after a MagIC Net update (see chapter 6.2,
page 15).

NOTE

Notes on migration in MagIC Net Multi

￭ Perform the migration on the server. Migration takes less time on the
server than on clients.

￭ Do not open the affected databases and methods on any client during
migration.

￭ During a database migration, do not run any determinations on any cli-
ent that uses the affected database.

￭ Do not start the affected methods on any client during a method migra-
tion.
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7.4 Checking access rights

After updating from MagIC Net 3.x to a higher version, check the access rights
and adjust them if necessary (see chapter 6.3, page 16).

7.5 Importing configuration data

If a configuration database with security settings or user administration is
imported, the settings of the imported configuration database are not applied
immediately.

Do not print the configuration report directly after importing a configuration
database. The printed settings do not correspond to the actual settings.

Check the security settings and user administration after importing a configura-
tion database. Otherwise there is a risk of being excluded from the application.
After the settings have been checked, restart the computer. In MagIC Net
Multi, restart all clients after importing a configuration database on a client.

Print the configuration report only after restarting the clients, if desired.

8 Adding additional licenses

General

The supported Windows versions have a UAC (User Account Control), which
permits running tasks either as non-administrator or as administrator (without
changes of user, switching off or similar). For more information about this
function, see https://docs.microsoft.com/en-us/windows/security/identity-pro-
tection/user-account-control/how-user-account-control-works.

This function can cause difficulties with client/server installations of
MagIC Net.

Problem description

Additional licenses for the program should be added. For this purpose, the
license code for an additional 5 licenses, for example, has been added (on the
server) in the Configuration program part in the Program administration
dialog window (accessible via the Tools ▶ Program administration... menu
item, Licenses tab).

Normally the license.mlic file, which contains the standard license code and
the additional license codes, is stored in the bin directory of the program
installation (e.g. C:\Program Files(x86)\Metrohm\MagIC Net\bin).

However, it may happen that the 5 licenses have been added and the
license.mlic file contains only the standard license code (for 3 licenses). If this
is the case, check whether there is a file named license.mlic in the C:\Users
\'Username\AppData\Local\VirtualStore\Program Files (x86)\Metrohm
\MagIC Net\bin directory. This file contains the license codes for the standard
licenses and the 5 newly added licenses, i.e. the additional licenses were stored

https://docs.microsoft.com/en-us/windows/security/identity-protection/user-account-control/how-user-account-control-works
https://docs.microsoft.com/en-us/windows/security/identity-protection/user-account-control/how-user-account-control-works


26 8.0102.8016EN / v1 / 2023-06-30

in the VirtualStore only for the Windows user who was logged in on the PC
at the time the additional licenses were added.

On the server, the program recognizes all of the licenses. The operating system
adds the license.mlic file from the C:\Users\'Username'\AppData\Local
\VirtualStore\Program Files (x86)\MagIC Net\bin directory to the detail
list of the C:\Program Files (x86)\Metrohm\MagIC Net\bin directory.

The license.mlic file in the C:\Program Files (x86)\Metrohm\MagIC Net
\bin directory determines the client/server functionality of the database server,
however, and here only the basic license is listed. Therefore, problems are to be
anticipated when adding additional clients (more than the 3 clients present in
the default settings). To fix this, the license.mlic file must be deleted from the
VirtualStore.

Remedy

￭ For new installations
– Start the program as an administrator.
– Add the license code for additional licenses as usual. The

license.mlic file in the C:\Program Files (x86)\Metrohm
\MagIC Net\bin directory contains both license codes.

￭ For existing installations
– In the C:\Users\'Username'\AppData\Local\VirtualStore\Pro-

gram Files(x86)\Metrohm\MagIC Net\bin directory, check
whether there is a file present named license.mlic and delete it if
necessary.

– Start the program as an administrator.
Add the license code for additional licenses as usual. The
license.mlic file in the C:\Program Files (x86)\Metrohm
\MagIC Net\bin directory contains both license codes.

9 User rights for MagIC Net

In order for the logged-in user to be able to access all functions with
MagIC Net, the Windows system administrator must ensure that the permis-
sions are set for the directories as listed below:

Directory Permission Group name or
user name

Database directory

Directory where the databases will be saved (…\Data).

Modify SYSTEM

User*

Backup directory

Directory where the backups will be stored (…\Backup).

Modify User*

%PROGRAMDATA%\Metrohm** Modify User*

Export directories

Directories where the exported files are to be saved.

Modify User*
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Directory Permission Group name or
user name

PDF directories

Directories where the PDF files are to be saved.

Modify User*

Desktop Modify User*

Installation directory, e.g. %PROGRAMFILES(x86)%
\Metrohm\MagIC Net

Read & execute User*

Temp directory: %ALLUSERSPROFILE%\Metrohm
\Temp\MagIC Net

Directory where the temporary files are saved.

Modify User*

* User = name of the user who is logged in

** During installation of MagIC Net the permission Full Control is set for the following groups:
SYSTEM, Administrators, Users, Guests, Main users.

NOTE

The BackupServer.exe process must be started for carrying out a backup
(backup of the configuration database and of the determination databases).
You can check this under "Windows Task Manager".

The user must be logged in during the whole backup process.
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